Home » RDBMS Server » Server Administration » Students in need;
Students in need; [message #369720] Fri, 25 August 2000 07:56 Go to next message
craig houghton
Messages: 2
Registered: August 2000
Junior Member
Please help me in this particular situation, I'm a student at Willis College trying to complete a project in COOP.
My requirement is to send email from Database through forms, using built-ins and PL\SQL Block. OS is windows NT version 4 service pack 5, and Oracle 8.1.5.
We have used the HOST built-in without any result. We've tried to approach it using the tcp_SMTP but we couldn't get it to work this way either. Any Suggestions?

Our Problem is the same as SIVA, who emailed you prior to us.
-------------
Her email included the following:

I am using utl_tcp package options to send the mail. Program is getting compiled. But when i try to execute the program, it is going to exception handling and when i display the error message it says "ORA 29540 class oracle/net/plsql/TCPconnection not available.
How will i add classes to already installed oracle?

We have a SMTP mail server. Is TCP utility function enough or should I use SMTP utilities. If so what should i do to execute the code. Already the TCP as well as SMTP pacakges are available in my database( I am able to view the packages and the functions inside).

If any one can help me to solve this problem, it will be great to me. My doubts are

Is TCP utility enough to send mail.
If so what should I do to overcome the ORA 29540 error ( Jave class not available error).
If not and if i have to use SMTP packages, can any one send me a piece of code ( which is already functioning).
------------
Please get back to us as early as possible as the requirement is urgent.

Thanks in Advance
Craig
Re: Students in need; [message #369724 is a reply to message #369720] Fri, 25 August 2000 16:57 Go to previous message
Lee
Messages: 56
Registered: May 1999
Member
It sounds like you need to run these 2 scripts to fix the error you are geting:

1 INITJVM.SQL
2 INITPLSJ.SQL

You have to be connected as SYS and run them in the order above, ONLY run these scripts if you made a custom installtion, if not CALL ORACLE.

I had the same problem and running the scripts fixed it.
Previous Topic: DECODE-How to include a virtual 'AND' or NOT EQUAL TO
Next Topic: Table almost too large to query
Goto Forum:
  


Current Time: Wed Oct 21 11:45:16 CDT 2020